fixed : Time Machine backup error “sparsebundle in use”

Question :

When Time Machine tried to backup today, it returned an error saying “Time Machine Error. The Backup disk image ….sparsebundle is already in use”. As I am the only one using this backup, I hoped that just trying to do the Time Machine backup manually would help… but it didn’t… it returned the same error…

Restarting my Mac didn’t help either…

How can I fix this ?

Answer :

The “sparsebundle already in use”-error occurs if something went wrong during the last backup (which could be because your Mac froze during the Time Machine backup). In that case your Mac did not properly disconnect from the Time Machine backup, so you will have to do so manually.

Fixing this is rather simple :

If you still have ‘the old’ Airport Utility 5.6 on your Mac (more info on this can be found here : https://macmanus.nl/2012/02/02/airport-utility-6-lost-the-option-to-configure-connected-printers/ ), you should do this :

–  open Airport Utility 5.6 (which is in the Utilities folder inside your Applications folder)

– select your Time Machine backup drive on the left (e.g. your Time Capsule)

– click on the “Manual” button

– then select the “Disks” icon

– and click on the “Disconnect All Users…” button

– then exit AirPort Utility 5.6 and run Time Machine normally

– …and do not forget to check in the time Machine Preferences if Time Machine is switched ‘ON’

if you do not have AirPort Utility 5.6 (since your Mac has OSX 10.8 “Mountain Lion” in stalled, which only has the stripped-down AirPort Utility 6 without the “Disconnect All Users”-option), you could either download and install AirPort Utility version 5.6 (directly from Apple : http://support.apple.com/kb/DL1482 ), or you should try this :

– shut down your Time Capsule a.k.a. “pull the power plug” (or other Time Machine backup drive)… and leave it disconnected for about 5 minutes or so

– restart your Mac

– power up your Time Capsule a.k.a. “plug the power cord back in” (or if you have some other sort of Time Machine backup drive, turn it back on)

– go to the Time Machine icon in the Finder’s top menu bar and click “Back Up Now”

– …and do not forget to check in the time Machine Preferences if Time Machine is switched ‘ON’

That’s it !

Donate Button (all)

Advertisements

2 thoughts on “fixed : Time Machine backup error “sparsebundle in use”

  1. This happend to me about a month ago – found a fix by goggling the error message. I thought it was fixed until today when the error message showed up again. I’m now trying what you suggested – do you know why this keeps happening?

    • @Andrea den Dulk :

      As indicated above :
      The “sparsebundle already in use”-error occurs if something went wrong during the last backup (which could be because your Mac froze during the Time Machine backup). In that case your Mac did not properly disconnect from the Time Machine backup, so you will have to do so manually.

      Put differently :
      At some moment in time your Time Machine backup did not properly complete, so your Mac did not properly disconnect from your backup drive.
      So even though Time Machine shut down, the sparsebundle (= backup file) was left ‘open’ as if it was still being used.
      The next time Time Machine started, it encountered the ‘open’ sparsebundle on the backup drive.
      And an ‘open’ sparsebundle can’t be used to start the next backup…
      So from that moment on, you will get the “sparsebundle already in use”-error whenever Time Machine tries to backup.

      Good Luck & Enjoy !

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s