fixed : 10.7.4 refusing to see the Atheros AR9280 (same error as in 10.7.3)

Question :

After the update to OSX 10.7.4 the “WiFi : no hardware installed” error is back on my Mac that has an Atheros AR9280 AirPort card, how can I fix this ?

Answer :

The solution is the same as in OSX 10.7.3 :

(Re)install the “Edited Atheros Kext for Lion*3″ you can download here :

https://macmanusnl.files.wordpress.com/2012/02/edited-atheros-kext-for-lion3-zip.doc

Note : after downloading the file “edited-atheros-kext-for-lion3-zip.doc” you need to rename the file to “edited-atheros-kext-for-lion3.zip” and double-click it to unzip. To install follow the instructions as lined out in the “CAUTION ! (Read Me).txt”-file

The latest version of the .kext-installer that’s needed can be downloaded here :

http://cvad-mac.narod2.ru/Kext_Utility

or here :

KextUtility for OSX 10.8

TIP : your Atheros AR9280 AirPort card and AirPort network are automatically detected when you restart in Rescue Mode… so restart with the ‘CMD’ + ‘R’ keys pressed (‘Rescue Mode’), then use Safari (listed as ‘online help’) to go online and download both files from the links above. If you get a warning that there’s no space in your download folder (because you’re in Rescue Mode), just go into Safari’s preferences and change the download folder to a USB-stick or external hard drive. Now do a normal restart and install the old .kext file and restart afterwards. Done.

Donate Button (all)

————————–

Some background info for those interested :

What is installed by the 10.7.4 installer :

IO80211Family.kext (v4.1.2)
– including these Plugins :
AirPortAtheros21.kext (v4.3.1)
AirPortAtheros40.kext (v5.0.4)
AirPortBrcm4331.kext (v5.3)
AppleAirPortBrcm43224.kext (v5.0.1)
IO80211NetBooter.kext (v4.2)

…which gives the “no hardware installed” error yet again on systems with the Atheros AR9280 AirPort-card…

What I’ve tried and didn’t work :

1- normal restart with ‘reopen windows when logging back in’ unchecked ; still the same ‘no hardware installed’ error

2- repair disk permissions, followed by a full shut down with ‘reopen windows when logging back in’ unchecked, followed by a normal startup ; still the same ‘no hardware installed’ error

3- installing the OSX 10.7.4 Client Combo Update (from Apple.com) ; still the same ‘no hardware installed’ error

Advertisements

fixed : 10.7.3 refusing to see the Atheros AR9280

UPDATE [2] :

Easiest fix so far (thanks to delifruit on InsanelyMac.com) :

(Re)installing the “Edited Atheros Kext for Lion*3″ you can download here :

https://macmanusnl.files.wordpress.com/2012/02/edited-atheros-kext-for-lion3-zip.doc

Note : after downloading the file “edited-atheros-kext-for-lion3-zip.doc” you need to rename the file to “edited-atheros-kext-for-lion3.zip” and double-click it to unzip, after that download the Kext Utility using the “kext-installer for Lion (Kext Utility by cVad)”-link included inside the unzipped folder ; to install follow the instructions as lined out in the “CAUTION ! (Read Me).txt”-file

the latest Kext Utility can be downloaded here :

KextUtility for OSX 10.8

Donate Button (all)

——————————

UPDATE [1] :

Apple seems to have acknowledged this problem, and has withdrawn the basic 10.7.3 update ; everyone will get the 10.7.3 combo update now :

http://www.macnn.com/articles/12/02/04/apple.fixes.lion.upgrade.issue.with.combo.switch/

And there’s a special fix for iMacs that have WiFi-problems since the OSX 10.7.3 update (but… it’s a iMac-only fix…) :

http://support.apple.com/kb/DL1501

I hope this fixes thing for all of us 😉

——————- ORIGINAL POST BELOW —————————-

The Atheros AR9280 was seen as a genuine AirPort-card by OSX…

…in 10.6 Snow Leopard

…and in 10.7 Lion it could even do AirDrop…

…until 10.7.3 that is…

10.7.3 for some mysterious reason lost it’s ability to detect the AR9280 at all…

…the AirPort-icon in the menubar is blank, and it lists “WiFi: no hardware installed”…

Oddly, when restarting the Mac mini in ‘Rescue mode’ (pressing Apple(CMD)+R during startup), AirPort instantly connects using that same AR9280 card… ???!!

…but that doesn’t last if you start up 10.7.3 the normal way.

So… after a lot of fiddling around I found the solution is quite easy :

Start by downloading the special .kext-installer here :

http://cvad-mac.narod2.ru/Kext_Utility

1- then… reinstall the IO8211Family.kext from 10.6 Snow Leopard and reboot (you can get that .kext-file from the Snow Leopard installer DVDrom)

if you only need WiFi-connection, that will do, but…

…if you also want to use AirDrop, you need to do step 2 also :

2- only after doing step 1, you will be able to successfully reinstall the IO8211Family.kext from 10.7.2 (the previous version of Lion ; the .kext-file you can get from your TimeMachine backup)

It is mind boggling why this works because :

– directly reinstalling the IO8211Family.kext from 10.7.2 onto the version in 10.7.3 doesn’t work – for some reason you need to downgrade to the Snow Leopard version first…

– the IO8211.kext from 10.7.3 appears to be exactly the same as the one from 10.7.2 ; they have the same version number (4.1.2) and have been created and modified at the exact same date…

…only thing is : this doesn’t seem to be an as stable solution as sticking with 10.7.2