fixed : install OSX 10.11 El_Capitan on unsupported Macs

Question :

I read somewhere that it is possible to install the latest version of OSX 10.10 Yosemite on my Mac, even though the official installer refuses to install.

Can you give me any directions ?

 

Answer :

Installing newer versions of OSX on slightly older Macs that do not meet the official system requirements can be done using MacPostFactor (MCPF).

MacPostFactor also supports installing OSX versions up to OSX 10.10 Yosemite on older Macs. And a new version that supports installing OSX 10.11 El_Capitan is in the works.

For more info (and downloads), go to the info page on MacRumors.com :

http://forums.macrumors.com/threads/os-x-yosemite-on-unsupported-macs-guide.1761432/

or see the (less readable) official page of the MacPostFactor team :

http://osxhackers.net/MCPF/

…in short :

!!! THIS IS FOR (RATHER) EXPERIENCED MAC-USERS ONLY, AND SHOULD NOT BE DONE ON YOUR ‘ONE AND ONLY’ MAC !!!

!! REMEMBER : DO FOLLOW THE COMPLETE INSTRUCTIONS THAT CAN BE FOUND HERE : MacPost Factor info page on MacRumors.com

…that should be it !

enjoy !

😉

Donate Button (MacManusNL)

Advertisements

fixed : install OSX 10.10 Yosemite on unsupported Macs

Question :

I read somewhere that it is possible to install the latest version of OSX 10.10 Yosemite on my Mac, even though the official installer refuses to install.

Can you give me any directions ?

 

Answer :

Installing newer versions of OSX on slightly older Macs that do not meet the official system requirements can be done using MacPostFactor (MCPF).

MacPostFactor (MCPF) also supports installing OSX versions up to OSX 10.10 Yosemite on older Macs. And a new version that supports installing OSX 10.11 El_Capitan is in the works.

For more info (and downloads), go to the info page on MacRumors.com :

http://forums.macrumors.com/threads/os-x-yosemite-on-unsupported-macs-guide.1761432/

or see the (less readable) official page of the MacPostFactor team :

http://osxhackers.net/MCPF/

…in short :

!!! THIS IS FOR (RATHER) EXPERIENCED MAC-USERS ONLY, AND SHOULD NOT BE DONE ON YOUR ‘ONE AND ONLY’ MAC !!!

!! REMEMBER : DO FOLLOW THE COMPLETE INSTRUCTIONS THAT CAN BE FOUND HERE : MacPost Factor info page on MacRumors.com

…that should be it !

enjoy !

😉

Donate Button (MacManusNL)

fixed : use unsupported scanner in OSX 10.11 El_Capitan

Question :

I have a Canon CanoScan LiDE 20 that used to work perfectly in MacOSX 10.6 Snow Leopard. But now I’ve bought a new Mac which runs OSX 10.11 El_Capitan, I can’t seem to install it, since Canon doesn’t update the drivers anymore.

What can I do ?

Answer :

In OSX 10.7 Lion, 10.8 Mountain Lion, 10.9 Mavericks, 10.10 Yosemite and 10.11 El_Capitan, any TWAIN-supporting scanner can be used without any additional software.

A list of supported scanners for OSX 10.9 Mavericks can be found here.

Here’s a quick step-by-step instruction :

– connect your scanner directly to your Mac using a USB-cable

– open the System Preferences

– then click on “Print & Scan”

– then, just below in the list of printers on the left, click on the “+”-sign

– that will bring up the “Add”-window, which enables you to add a new printer or scanner

– if your scanner is TWAIN-supporting, it will show up there, and you just need to select it and click on the “Add”-button

– then it will be listed in the previous (“Print & Scan”) System Preferences window, and if you select it (and you put a piece of paper or a photo in the scanner), a Scanning Preview window will show up, allowing you to scan your document to file or eMail or something else…

but…

…for some printers, like the Canon CanoScan LiDE 20 and LiDE 30, the TWAIN-drivers are not included in OSX. In that case, you will need to install some generic (FREE) TWAIN-drivers :

IMPORTANT : do not forget to read this entire post, even all the notes at the bottom ! e.g. if you have an old CanoScan scanner, you might have to reinstall TWAINbridge.app also !

– for OSX 10.11 El_Capitan, download and install these files (in this same order) and restart you Mac after doing so, then your scanner will also show up in the “Print & Scan” System Preferences :

LibUSB for OSX 10.11

SANE Backends for OSX 10.11

SANE Preference Pane for OSX 10.11

TWAIN SANE Interface for OSX 10.11

for OSX 10.10 Yosemite, download and install these files (in this same order) and restart you Mac after doing so, then your scanner will also show up in the “Print & Scan” System Preferences :

libusb.pkg.tar.gz

sane-backends.pkg.tar.gz

SANE-Preference-Pane.pkg.tar.gz

TWAIN-SANE-Interface.pkg.tar.gz

– for OSX 10.9 Mavericks, download and install these files (in this same order) and restart your Mac after doing so, then your scanner will also show up in the “Print & Scan” System Preferences :

libusb.pkg.tar.gz

sane-backends.pkg.tar.gz

SANE-Preference-Pane.pkg.tar.gz

TWAIN-SANE-Interface.pkg.tar.gz

– for OSX 10.8 Mountain Lion, download and install these files (in this same order) and restart your Mac after doing so, then your scanner will also show up in the “Print & Scan” System Preferences :

libusb.pkg.tar.gz

sane-backends.pkg.tar.gz

SANE-Preference-Pane.pkg.tar.gz

TWAIN-SANE-Interface.pkg.tar.gz

– for MacOSX 10.7 Lion, download and install these files (in this same order) and restart your Mac after doing so, then your scanner will also show up in the “Print & Scan” System Preferences :

libusb.pkg.tar.gz

sane-backends.pkg.tar.gz

SANE-Preference-Pane.pkg.tar.gz

TWAIN-SANE-Interface.pkg.tar.gz

– if these files do not turn into regular .pkg-files when you click on them, you need unTAR-software like this :

The Unarchiver

– if you get an error-message telling you you can’t install this software (these drivers) since the are not from Apple-appoved developers, you need to :

– open the System Preferences

– then click on “Security & Privacy”

– then make sure the “General”-tab is selected

– click the padlock in the lower left corner and provide an Administrator name & password to unlock the padlock

– then at “Allow applications downloaded from:” select “Anywhere”

– and exit the System Preferences to make this setting stick

Note #1 :

TWAIN-supporting drivers (like SANE and the ones that come with OSX) will enable you to directly scan from within various applications like Photoshop, MS Word, GraphicConverter, OmniPage and OSX’s built-in Image Capture. [ please also read Note #7 and #8 for more tips on this ! ]

Alex Scheider has written a special SANE scanner app for OSX 10.7 and newer, you can download it here. A screenshot can be found here[haven’t tested it, so feedback on this is welcome]

Note #2 :

when using the SANE drivers, you will probably not be able to use the ‘one click’-buttons that are on the scanner itself…

Note #3 :

if your scanner lets you scan the first time, but after shut-down and restart scanning seems impossible because OSX can’t find the scanner, just plug-out the scanner’s USB-cable and plug it back in and everything should work again…

Note #4 :

if the “Scan”-button remains grayed-out, make sure that you have selected an area to scan… (put differently : if “Selection:” is set to “Off”, you will need to select an area to scan before the “Scan”-button will be ready to use…)

Note #5 :

if you get a distorted scan when scanning in landscape view (or any other rotated view), just scan normally in portrait view and rotate the scanned image afterwards (in Preview app or another image editing program, like Photoshop or Graphic Converter)

Note #6 :

if you are not able to scan as a JPEG (.jpg-flie), just scan as a TIFF (.tif-file) and convert the scanned image afterwards (in Preview app or another image editing program, like Photoshop or Graphic Converter)

Note #7 :

if your scanner doesn’t show up in Image Capture (especially in OSX 10.9 Mavericks), use this workaround :

go to System Prefecences –> Printers & Scanners –> [your scanner] –> Scan –> Open Scanner

Note #8 :

if your scanner doesn’t show up in Photoshop (especially in OSX 10.9 Mavericks), try this workaround :

go to Applications –> Adobe Photoshop CS# –> Adobe Photoshop CS# –> type “CMD” + “i” key-combo (on your keyboard) –> (in the Get Info window) select “Open in 32 bit mode” and exit Get Info

then open Adobe Photoshop (CS#-version) –> File –> Import –> SANE

Note #9 :

another option that might just work to get SANE drivers to connect with ImageCapture and Photoshop (especially if you have an older CANON scanner) is (re)installing the TWAINbrigde.app that Jan Egil has ready for download on his website.

for now, there is no version of TWAINbridge.app that runs in OSX 10.11 El_Capitan, the alternative seems to be to use the old CanoScan Toolbox 5.0 software that can be found on the Canon website or here

Credits :

Matias Ellert and the Open Source developers of the SANE project

…and a special thanks to Mónica, Jorge Blasio, torrealta, dencho, BobD and Jan Egil for Note #7, #8 and #9 ! [see comments below]

If you encounter any problems with these SANE drivers for OSX, try contacting Mattias Ellert directly as indicated here.

If you want to un-install the TWAIN SANE drivers, either use an un-installer application like AppCleaner or follow the instructions for manual un-install as outlined in Mattias Ellert’s FAQ (last question & answer).

Donate Button (MacManusNL)