fixed : connection error using Canon CanoScan 5600F with macOS 10.15 Catalina

Question :

I have been using my Canon CanoScan 5600F scanner for many years with my Mac, and it has always been working great. However : now, in macOS 10.15 Catalina I keep getting error messages that the scanner cannot be found…

Sometimes I manage to get things working by replugging the USB-cable and switching the scanner OFF and back ON, but that solution doesn’t last…

What can I do to solve this ?

 

Answer :

even though Canon does not list support for macOS 10.15 Catalina, the Canon driver that used to work in MacOSX 10.7 Lion through macOS 10.14 Mojave still works in macOS 10.15 Catalina, so if you do not have this driver already, download it here

To solve your problem, do this :

  • go to Apple-icon (top left in the menu bar) and click on “System Preferences” from the pulldown menu
  • in the “System Preferences” window, click on “Printers & Scanners”
  • in the list on the left, at “Scanners”, select your CanoScan 5600F
  • then, click on the Minus-button at the bottom of the list on the left, to delete the scanner from the list
  • now, switch OFF your scanner and unplug the USB-cable from the scanner and from your Mac
  • then, go to Apple-icon (top left in the menu bar) and click on “Restart…” from the pulldown menu
  • when prompted, UNcheck the option to reopen all open windows and restart your Mac
  • then, plug the USB-cable back into your scanner and your Mac and switch your scanner back ON
  • when your Mac has restarted, open System Preferences
  • in the “System Preferences” window, click on “Printers & Scanners”
  • in the list on the left, at the bottom, click on the Plus-button
  • in the window that opens, select your CanoScan 5600F from the list and click the “Add”-button
  • you can now select your CanoScan 5600F from the list on the left and click on the “Open Scanner” button on the right to open it
  • now, the “Scanner” window will open and you will be able to scan

Note : you might encounter the ‘scanner cannot be found’ error again… if so, just delete the scanner from System Preferences, then add it again… [if you cannot live with getting this error once in a while, and you cannot wait for Apple and/or Canon to come up with a definite solution… have a look at the VueScan scanner-app]

That’s it !

enjoy ūüėČ

tip : which scanners are compatible with OSX 10.9 Mavericks ?

Question :

Which scanners will work with OSX 10.9 Mavericks ?

Answer :

Just like with previous versions of MacOSX, the built-in compatibility with older scanners is rather low…

…in the specs of OSX 10.9 Mavericks there isn’t any indication of extended scanner support, so it is expected that “wireless scanning” (over WiFi/AirPort) isn’t supported either, just as was the case (or should I say “problem”) in previous versions of MacOSX…

Apple hasn’t published a list of pre-installed scanner-drivers either, so there’s nothing official on this…

…there is however, a (very short) list of supported scanners pre-installed in OSX 10.9 Mavericks itself :

CanoScan 5600F             find it in the US, UK or Germany
CanoScan 9000F             find it in the US, UK or Germany
CanoScan LiDE 100         find it in the US or Germany
CanoScan LiDE 110         find it in the US, UK or Germany
CanoScan LiDE 200         find it in the US, UK or Germany
CanoScan LiDE 210         find it in the US, UK or Germany
CanoScan LiDE 700F       find it in the US, UK or Germany

This list can be found in :

/Library/Printers/Canon/IJScanner/Resources/CIJIcons

…strangely, there are no such icons installed for scanners from other brands like EPSON and HP… so support for those scanners is either not included (yet) or left up to the individual manufacturers…

NOTE #1 : in MacOSX 10.7 Lion, OSX 10.8 Mountain Lion and OSX 10.9 Mavericks scanner-compatibilty can be extended by installing the SANE-scannerdrivers, as outlined here.

NOTE #2 : if you are a professional and/or heavy user, you could also try using the SilverFast 8 scanner-suite, which adds support for these scanners to OSX 10.9 Mavericks (since even the cheapest version, SilverFast SE 8, will cost you ‚ā¨50, this only is a relevant solution for professional and/or heavy users…)

Donate Button (MacManusNL)