fixed : install OSX 10.8 Mountain Lion on unsupported Macs

Question :

I read somewhere that it is possible to install the latest version of OSX 10.8 Mountain Lion on my Mac, even though the official installer refuses to install.

Can you give me any directions ?

Answer :

Updated answer :

MLPostFactor has been succeeded/replaced by MacPostFactor, and is now being updated by a new crew of programmers. MacPostFactor also supports installing OSX versions up to OSX 10.10 Yosemite on older Macs. And a new version that supports installing OSX 10.11 El_Capitan is in the works.

For more info (and downloads), go to the info page on MacRumors.com :

http://forums.macrumors.com/threads/os-x-yosemite-on-unsupported-macs-guide.1761432/

 

Original answer :

Yes, thanks to the guys from MLPostFactor, it’s now possible to install OSX 10.8 Mountain Lion (even 10.8.4) on these older Intel-Macs :

Early 2006 (and newer) versions of the iMac and Mac mini

Late 2006 (and newer) versions of the Macbook, MacBook Pro, Mac Pro and Xserve

Early 2008 (and newer) versions or the Macbook Air

…and I must say : “(in my case) it runs smoother than MacOSX 10.7”, but there are a few downsides, especially these ones :

– regular OSX updates are disabled, you can only use a special OSX-update routine

– some (but very little) software is not compatible due to various reasons ; e.g. PhotoBooth, Little Snitch

– the SMB client is not working properly (the SMB server is), so file transfer is crippled

– it’s provided “as-is”, so no support from anyone (neither the developer nor me), and no guarantee it will fully or even partially work in your case (especially not if you do not strictly follow all of the directions !!)

…in short :

!!! THIS IS FOR (RATHER) EXPERIENCED MAC-USERS ONLY, AND SHOULD NOT BE DONE ON YOUR ‘ONE AND ONLY’ MAC !!!

What you need :

– one of the Intel-Macs mentioned above (running MacOSX 10.7 Lion and at least 2GB of RAM)

– an official version of the OSX 10.8 installer, (re)downloaded from the Mac App Store inside your Applications Folder (sorry, pirated versions don’t work…)

– the 32-bit MLPostFactor v3.0 installer-patcher (should be put inside your Applications folder also) you can download from here :

http://www.osxhackers.com/Download.html

or alternatively :

http://mac.softpedia.com/get/System-Utilities/MLPostFactor.shtml

– a full backup of your current harddrive running OSX 10.7 Lion and all your personal files (simply put : “a Time Machine backup of your Mac”)

– a partition of 8GB to create the patched OSX 10.8 installer on ; according to the official directions this should be a partition on your main harddisk called “Install”, but it turns out that ‘if you dare’ you can also use an 8GB USB-stick or an 8GB partition on an external USB- or FireWire-harddisk for this [simply put, MLPostFactor does what Lion DiskMaker does AND includes a patch that’s needed for older Intel-Macs]

– a partition of at least 10GB called “ML” to install the new (patched) OSX 10.8 Mountain Lion onto ; this is will to be your final, ‘new’ harddrive for your ‘old’ Mac… it turns out that ‘if you dare’ you can assign this to your current MacOSX 10.7 Lion harddrive [provided you have a good (TimeMachine) backup]

Exact directions on how to install can be found here :

http://www.osxhackers.com/Installation.html

…or the video that HackerWayne (one of the MLPostFactor developers) has issued :

http://www.youtube.com/watch?v=YqMgrPKfrqM

You should follow the step-by-step instructions above, but just to give a quick impression of the routine :

– make a Time Machine backup and make sure both the OSX 10.8 installer and MLPostFactor are in you Applications folder

– run MLPostFactor to create the patched installer (8GB) for OSX 10.8.4 (or an other version if you prefer that one for some reason…)

– reboot from the patched installer and install the patched OSX 10.8 onto (the desired partition of) the internal harddrive

– this will either end in an error or a white screen (seemingly ‘hung’)

– reboot from the patched installer and run MLPostFactor from there onto the partition you have just installed OSX 10.8 on (= your internal harddrive)

– then reboot from the fresh OSX 10.8 partition (= your internal harddrive)

– if you get a “WiFi: No Hardware Installed”-error, get the KextUtility for OSX 10.8 and install the Edited Atheros Kext for Lion*3

!! REMEMBER : DO FOLLOW THE COMPLETE INSTRUCTIONS THAT CAN BE FOUND HERE :

http://www.osxhackers.com/Installation.html

or the ‘official’ video :

http://www.youtube.com/watch?v=YqMgrPKfrqM

…that should be it !

enjoy !

😉

Donate Button (MacManusNL)

Advertisements

tip : using Evernote on an iBook G4 or iMac G5

Question :

I have Evernote running on my iPhone, my iPad and my MacBook, but I would also like to use it on my old Mac which has a Power-PC (G4/G5) processor.

On the Evernote-website I can only download the latest version of Evernote, which is Intel-Mac only…

How can I use Evernote on my old iMac G5 and iBook G4 ?

 

Answer :

If you are running MacOSX 10.5 “Leopard” on your PPC-Mac (G4/G5), you can use the previous version of Evernote, which can be found here :

http://cl.ly/1I3a0Y3f26282k3p2a0E

If you are still running MacOSX 10.4 “Tiger” (or newer) your only option is to use the online version of Evernote, which can be accessed here :

https://www.evernote.com/Home.action

tip : play some Plants vs Zombies on your Mac for free

Question :

I wanted to play the Plants vs Zombies game on my PowerPC (G4/G5) Mac, so I downloaded the demo from the PopCap-website. It installs okay, but when I try to play, nothing happens…

What can I do ?

Answer :

Even though the Plants vs Zombies game is compatible with MacOSX 10.4.11 “Tiger” and newer, it is only compatible with Intel-Macs… so you cannot play the demo, nor the full game on any PowerPC (G4/G5) Mac…

but…

even with a G4 & G5 PPC Macs running OSX 10.5 Leopard you can play the online version…

just use your web browser, and play online from PopCap’s official Plants vs Zombies website :

Plants vs Zombies Chrome (also runs in Safari 5) :

http://chrome.plantsvszombies.com/

info : are you ready for Mountain Lion ?

Apple is getting everything in place for the release of OSX 10.8 “Mountain Lion” due later this month.

The names of the Macs that will be able to run OSX 10.8 “Mountain Lion” have been published on the Apple website :

http://www.apple.com/osx/how-to-upgrade/

From eldest to newest these Macs are :

– iMac “mid 2007” or newer (so any “Aluminum” iMac)

– MacBook Pro “mid/late 2007” or newer (so any MacBook Pro with an NVIDIA graphics card)

– Mac Pro “early 2008” or newer (so any Mac Pro with the Xeon 5400 “Harpertown” processors or newer)

– MacBook Air “late 2008” or newer (so any MacBook Air with Thunderbolt or MiniDisplayPort)

– MacBook “Aluminum” = “late 2008″ (so the 13” MacBook Pro look-alike)

– MacBook “White – early 2009” or newer (so only the ‘original’ white polycarbonate design versions that have an NVIDIA graphics card)

– Xserve “early 2009” (so only the latest generation with Xeon 5500 “Gainestown” processors)

– Mac mini “early 2009 & late 2009” (so only the original Mac mini design that have an NVIDIA graphics card)

– Mac mini “Aluminum” = “mid 2010” or newer (so any Mac mini of the extra flat redesign)

…that’s the bad news (for some  – those of us with older Macs…)

and the good news is :

you don’t need to have MacOSX 10.7 “Lion” installed to upgrade, you only need MacOSX 10.6 “Snow Leopard” with the “Mac App Store” application (since OSX 10.8 “Mountain Lion” is only available from the Mac App Store…)

info : setting up Back To My Mac through a TG712 modem-router

Question :

How do I setup my Thomson TG712 modem-router to allow me to use the the Back To My Mac function of my Macs ?

Answer :

Here’s how to turn on Back To My Mac when you have a TG712 modem-router :

– on your Mac, go to Apple —> System Preferences —> iCloud

– then put a check mark at “Back To My Mac” to turn the service on

– if there’s a “More…”-botton click it, just for your information ; if a warning is listed, read it, keep it in mind, and don’t bother…

– then open Safari (or any other internet browser) on your Mac, and type the web based control panel’s IP-address of your router-modem as the URL ; for the TG712 router- modem, the IP-address is 192.168.1.254

– in the web based control panel, go to “Toolbox” (in the menu on the left) –> “Games & Apps Sharing” (in the menu on the left)

– then in the middle of the page, at the bottom, from the “Choose a task…” list, click on “Add a game or application to a local networking device” (the first link in the list)

– in the page that opens, put check marks both at “Use UPnP:” and “Use extended security:”

– and set the “Game or App”-dial (the one that is initially at “ABC (Another Bittorent Client)”) to “Back To My Mac”

– set the “Device”-dial to your Mac (which is the Mac that you would like to use with Back To My Mac, so probably your Mac-server or desktop-Mac)

– just to be able to trace possible errors, put a check mark at “Logging”

– then click on the “Add”-button

– wait for the router-modem to restart

– logout by closing the browser-page with the web based control panel on it

Now you should be able to log into your (home) Mac, when being at a remote location (if there’s internet connection there…)

Donate Button (all)

fixed : quickly share your Mac’s internet connection to your iPad

Question :

I just got myself a WiFi-only iPad, but I have no WiFi reception in my living room (that’s why my Mac in my living room is connected to my network through an Ethernet/UTP-cable). Is there an easy way to get internet connection on my iPad in my living room ?

Answer :

Yes, there is.

Your Mac can share it’s internet connection from one of it’s internal network-connections to another. So from Ethernet to WiFi in your case.

To get it working is easy :

– turn on your Mac (if your Mac isn’t running, this won’t work)

– go to System Preferences (under the Apple-dropdown menu in the upper left corner of the desktop/Finder-menu)

– in the window that opens, click on “Sharing”

– in the screen that opens, click on “Internet Sharing” in the list on the left

– then, on the right, select your incoming network/internet connection at “Share your connection from:” (so, in this case select “Ethernet” there)

– and then select your outgoing internet connection at “To computers using:” (so, in this case put a check mark at “Wi-Fi”)

– if you want your shared internet to be password protected, click on the “Wi-Fi Options…”-button and choose your preferred network name, the preferred password protection protocol and your preferred password. If you don’t need protection, just leave everything as-is.

– then put a check-mark at “Internet Sharing” in the list on the left and quit System Preferences

– now you will see that your AirPort/WiFi-pie icon in the upper right of the desktop / finder-menu has turned into a new icon with an arrow pointing upward.

– then, on your iPad (or iPhone or any other WiF-connectable device) go to Settings, click on WiFi and select your new local WiFi-network

– done ! enjoy !

Note : you’ve just turned your Mac into a local WiFi-router (also), so remember that your Mac has to be switched on to sustain the WiFi-network connection

tip : planning on buying Apple stuff ?

If you’re planning on buying Apple hardware, be it an iPod Shuffle, iPod Nano, iPod Classic, iPod Touch, iPhone, iPad, MacBook Air, MacBook, MacBook Pro, Mac mini, iMac, Mac Pro or Cinema Display, you should consider checking if now is the right time to buy first.

MacRumors’ Buying Advice doesn’t advice you on what product to buy, just on WHEN to buy and when not to buy (which means : “hold on and wait just a little until the product gets refreshed”) :

http://buyersguide.macrumors.com/

MacRumors’ Buying Advice is based on the regularity of the product cycles of Apple hardware (not on the rumors, but current rumors on upcoming hardware are listed also …as MacRumors originally is an Apple rumor site…)

The ‘advice’ categories are :

Buy now! Product just updated

Buy only if you need it – Approaching the end of a cycle

Don’t buy – updates soon

[ for your convenience, I also included this “When (not) to buy ?” link as an extra at the (static) top of this website ]